Site may be down
Incident Report for Kidz
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 12:01 UTC
Monitoring
A Fix Has been implemented. If you an issue please report it to our support email (kidz.glitch.me/support)
Posted May 28, 2020 - 16:02 UTC
Investigating
Glitch (our host) are investigating an issue that is causing a drop in project container availability. Some projects may not be loading at this time. For updates go to https://status.glitch.com.
Posted May 28, 2020 - 15:28 UTC
This incident affected: Website.