Glitch Editor may not loading
Incident Report for Kidz
Resolved
This incident has been resolved.
Posted Jun 11, 2020 - 12:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 02, 2020 - 12:04 UTC
Investigating
The Glitch editor is what we use to manage Kidz. It may not be working.
Posted Jun 02, 2020 - 12:03 UTC
This incident affected: Editor and Website.