Current 404 Errors
Incident Report for Kidz
Resolved
This incident has been resolved.
Posted May 26, 2020 - 15:21 UTC
Investigating
We still working on the system but the main editor Is having some 404 error's ...
Posted May 25, 2020 - 19:10 UTC
This incident affected: Editor and Website.